Letysite.ru

IT Новости с интернет пространства
0 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Как сделать чтобы excel не округлял

Округление чисел в Microsoft Excel

Редактор таблиц Microsoft Excel широко применяется для выполнения разного рода вычислений. В зависимости от того, какая именно задача стоит перед пользователем, меняются как условия выполнения задачи, так и требования к получаемому результату. Как известно, выполняя расчёты, очень часто в результате получаются дробные, нецелые значения, что в одних случаях хорошо, а в других, наоборот, неудобно. В этой статье подробно рассмотрим, как округлить или убрать округление чисел в Excel. Давайте разбираться. Поехали!

Для удаления дробных значений применяют специальные формулы

О существовании специальной функции округления в Экселе знают далеко не все пользователи. Случается, что некоторые из них ошибочно принимают формат значений, то есть отображаемое количество знаков после запятой, за округление. Далее в статье разберёмся, что к чему и как всё делается.

Для начала отметим, что функция «Формат числа» применяется в случаях, когда вид числа необходимо сделать более удобным для чтения. Кликните правой кнопкой мыши и выберите в списке пункт «Формат ячеек». На вкладке «Числовой» установите количество видимых знаков в соответствующем поле.

Но в Excel реализована отдельная функция, позволяющая выполнять настоящее округление по математическим правилам. Для этого вам понадобится поработать с полем для формул. Например, вам нужно округлить значение, содержащееся в ячейке с адресом A2 так, чтобы после запятой остался только один знак. В таком случае функция будет иметь такой вид (без кавычек): «=ОКРУГЛ(A2;1)».

Принцип прост и понятен. Вместо адреса ячейки вы можете сразу указать само число. Бывают случаи, когда возникает необходимость округлить до тысяч, миллионов и больше. Например, если нужно сделать из 233123 — 233000. Как же быть в таком случае? Принцип тут такой же, как было описано выше, с той разницей, что цифру, отвечающую за количество разделов, которые необходимо округлить, нужно написать со знаком «-» (минус). Выглядит это так: «=ОКРУГЛ(233123;-3)». В результате вы получите число 233000.

Если требуется округлить число в меньшую либо в большую сторону (без учёта того, к какой стороне ближе), то воспользуйтесь функциями «ОКРУГЛВНИЗ» и «ОКРУГЛВВЕРХ». Вызовите окно «Вставка функции». В пункте «Категория» выберите «Математические» и в списке ниже вы найдёте «ОКРУГЛВНИЗ» и «ОКРУГЛВВЕРХ».

Ещё в Excel реализована очень полезная функция «ОКРУГЛТ». Её идея в том, что она позволяет выполнить округление до требуемого разряда и кратности. Принцип такой же, как и в предыдущих случаях, только вместо количества разделов указывается цифра, на которую будет заканчиваться полученное число.

В последних версиях программы реализованы функции «ОКРВВЕРХ.МАТ» и «ОКРВНИЗ.МАТ». Они могут пригодиться, если нужно принудительно выполнить округление в какую-либо сторону с указанной точностью.

Как вариант, решить проблему можно при помощи функции «ЦЕЛОЕ», принцип которой заключается в том, что дробная часть просто отбрасывается, округляя вниз.

Иногда программа автоматически округляет полученные значения. Отключить это не получится, но исправить ситуацию можно при помощи кнопки «Увеличить разрядность». Кликайте по ней, пока значение не приобретёт нужный вам вид.

Теперь, когда вы разбираетесь, как выполнять округление числа, вам будет проще выполнять ряд задач в программе. Кроме того, эти навыки помогут вам и в решении повседневных вопросов, связанных с расчётами.

Если Excel округляет длинные числа

Если вы вставите в числовую ячейку длинное число с более, чем 15 разрядов, то Excel округлит его и выдаст нечто совсем непригодное. Например, число 893800399000003570 он покажет в виде 8,938E+17, а если по нему кликнуть, покажет его, как 893800399000003000. Здесь мы видим потерю последних трёх разрядов, что совершенно неприемлемо.

Решить проблему можно, если изменить формат ячейки или колонки с числового на текстовый. Тогда вставляемое число любой разрядности не будет преобразовываться. Также можно вставить его в числовую ячейку, если перед числом использовать знак одинарных кавычек.

Однако при преобразовании таких строчных записей в число Excel снова округляет все разряды больше 15-ти. Поэтому такой способ подходит лишь для представления больших чисел в таблице, а для вычислений они всё равно должны преобразовываться с потерями. Сделать с этим ничего нельзя – Excel так устроен, и 15 разрядов – предельная его точность, с которой можно записывать числа в таблице.

Пишите в комментариях были ли статья полезной для вас и продолжайте совершенствовать навыки работы в Microsoft Excel.

Округление чисел в Microsoft Excel

Функционал Microsoft Excel огромен, и одной из главных возможностей программы является работа с числовыми данными. Иногда во время арифметических операций или при работе с дробями программа эти числа округляет. С одной стороны, это практично, поскольку в подавляющем большинстве случаев высокая точность расчетов не нужна, и множество лишних знаков только занимает дополнительное место на экране. Кроме того, есть числа, дробная часть которых бесконечна, поэтому для отображения на экране приходится их немного сокращать. С другой – бывают расчеты, где точность сохранять просто необходимо, а округление приводит к неприятным последствиям.

Для решения подобных вопросов Эксель предлагает следующее решение – задать точность округления пользователь может самостоятельно. Таким образом, программа может быть настроена для вычислений любых видов, позволяя каждый раз находить оптимальный баланс между удобством отображения информации и необходимой точностью вычислений.

Как числа хранятся в Excel и отображаются на экране

Программа Excel умеет работать с двумя типами чисел: точными и приблизительными. Пользователь может выбирать способ их отображения, однако, в самой программе число хранится в точном виде (до 15 знаков после запятой). Поэтому, даже если на экране число будет отображаться до двух знаков после запятой, при расчетах программа будет обращаться к гораздо более точной записи в памяти.

Читать еще:  Не печатается текст в word

Пользователь может настроить то, как это число будет показано на экране. А округление происходит по общепринятым нормам: числа от 0 до 4 включительно округляются вниз, а с 5 до 9 – вверх.

Настройка отображения чисел через панель инструментов

Самый простой способ округлить число, а точнее, его отображения на экране – через кнопки на Панели инструментов. Чтобы найти их, должна быть открыта вкладка “Главная”, в которой расположен подраздел “Число”. Здесь и находятся требуемые функции “Увеличить разрядность” или “Уменьшить разрядность”.

Выберите ячейку с числом и нажмите на кнопку с нужным действием. Функция “Увеличить разрядность” будет добавлять в конец дробной части нули.

Функция “Уменьшить разрядность” будет убирать цифры с конца, округляя окончания.

Примечание: Важно помнить, что числовое значение, которое хранится в памяти программы после проделанных действий никак не изменится, и расчеты будут производиться с исходным значением.

Формат чисел через контекстное меню

Нужную степень отображаемого на экране округления можно изменить и другим способом – через контекстное меню ячейки.

  1. Выделяем нужную ячейку (или область, состоящую из нескольких ячеек) и кликаем по ней правой кнопкой мыши. В контекстном меню выбираем пункт “Формат ячеек…”.
  2. Откроется окно, в котором в верхнем меню переходим во вкладку “Число” (по умолчанию должна быть установлена именно эта вкладка). В списке слева выбираем “Числовой” формат. Справа находим надпись “Число десятичных знаков”, рядом с которым есть текстовое поле для выбора количества знаков дробной части. Можно ввести его самостоятельно или дойти до нужного значения путем нажатия на стрелки вверх или вниз.
  3. Далее нажимаем на “ОК”, после чего изменения вступят в силу.

Примечание: Также можно поставить галочку напротив надписи “Разделитель групп разрядов”, чтобы при отображении больших чисел разграничить группы разрядов.

Как задать числам требуемую точность при расчетах

Предыдущие примеры затрагивали то, как настроить визуальное отображение числового значения. Но Эксель позволяет задать и точность самих операций с числами. Это полезно, например, при финансовых расчетах, где обычно используются числа только с двумя цифрами после запятой.

Для изменения данного параметра откройте вкладку “Файл” в верхнем меню программы. В новом окне найдите строку “Параметры” в списке слева и нажмите на нее.

На экране должно появиться окно настройки параметров. Здесь переходим в раздел “Дополнительно”, далее находим внизу правой части окна подраздел “При пересчете этой книги”, в котором предлагается выбрать четыре параметра. Напротив второго из них (“Задать указанную точность”) устанавливаем галочку и нажимаем “OK”.

С этого момента при расчетах будет использоваться то значение, которое вы на мониторе.

Важно: Обратите внимание, что настройка будет применена к файлу целиком, а не к отдельному листу, из которого были открыты настройки.

Использование функций округления

Иногда нужно поменять точность расчетов с числовыми данными не для всего файла, а лишь для определенной области ячеек. В этом случае лучшим решением будет использование встроенных функций для работы с округлением чисел, которых существует несколько видов. Вот самые удобные и наиболее популярные:

  • ОКРУГЛ – округление до числа с указанным количеством знаков после запятой по правилам математики.
  • ОКРУГЛВВЕРХ – округление до ближайшего большего значения (по модулю).
  • ОКРУГЛВНИЗ – округление до ближайшего меньшего значения (по модулю).
  • ОКРУГЛТ – округление числа с желаемой точностью.
  • ОКРВВЕРХ – округление с избытком до ближайшего числа, которое кратно заданному значению точности.
  • ОКРВНИЗ – округление с недостатком до числа ближайшего числа, которое кратно заданному значению точности.
  • ОТБР – округление до целого числа путем отбрасывания цифр после запятой.
  • ЧЁТН – округление до ближайшего четного числа.
  • НЕЧЁТ – округление до ближайшего нечетного числа.

Обобщенная формула для первых трех функций выглядит так: ФУНКЦИЯ([число];[количество цифр]). Например, для округления числа 3,14159265 до двух знаков после запятой, нам понадобится следующая формула: =ОКРУГЛ(3,14159265;2).

Пишем ее в нужную ячейку, не забывая в начале поставить знак равно.

После набора формулы щелкаем клавишу Enter и получаем в результате число 3,14.

В формулах функций ОКРУГЛТ, ОКРВВЕРХ и ОКРВНИЗ в качестве второго аргумента указывается кратность округления. Например, если стоит задача округлить число 13 до ближайшего числа, делящегося на 5 без остатка, следует написать следующую формулу: =ОКРУГЛТ(13;5).

Результатом вычисления будет число 15.

Последние три функции (ОТБР, ЧЁТН и НЕЧЁТ) используют всего 1 аргумент – само число или ячейка. Первая из них просто вернет его целую часть, а вторая и третья – ближайшее четное или нечетное числа, соответственно.

Сами функции можно прописать как внутри ячейки, так и в верхней строке формул, которая находится справа от надписи fx.

После того, как вы начнете вводить название функции, программа выдаст подсказки, благодаря которым можно выбрать точное название и избежать возможных опечаток. Перед написанием формулы не забывайте ставить знак равно (“=”).

В дополнение ко всему, есть возможность вызвать функци через вкладку “Формулы”. Откройте ее и выберите “Математические”. Появится список всех функций, расположенных по алфавиту, поэтому для поиска округления (ОКРУГЛ) нужно идти в нижнюю часть списка.

После того, как мы выберем нужную функцию, откроется окно для ее настройки.

В строке “Число” пишем координаты ячейки, значение которой нужно округлить. Также, вместо того, чтобы писать адрес ячейки вручную, можно просто находясь курсором в строке “Число” щелкнуть левой кнопкой мыши по нужной ячейке.

Читать еще:  Net use user password

Далее переходим к строке “Число разрядов” и здесь пишем число знаков после запятой. Допустим, в нашем случае, пусть это будет 2.

После того, как все заполнено, нажимаем “OK” и получаем результат в первой строке, куда была вставлена функция округления.

Чтобы применить расчеты к остальным строкам столбца, наводим мышью на нижний правый угол ячейки, содержащей формулу. Курсор поменяет свой вид на небольшой крестик. Теперь, зажав его левой кнопкой мыши тянем формулу на оставшиеся строки, по которым нужно произвести расчет, после чего отпускаем кнопку.

Заключение

Таким образом, в Excel есть два способа произвести округление отображаемой части числа: через панель инструментов и через Формат ячеек. Однако, при этом система будет помнить все число целиком и использовать именно его при расчетах. Поэтому, чтобы изменить само число или задать его точность в расчетах, необходимо либо воспользоваться одной из функций округления, либо изменить настройки в параметрах программы.

Функции округления в Excel

В Excel часто используют округление чисел. В данной заметке рассмотрим разные типы округления, которые встречаются на практике.

Некоторые новички допускают ошибку, пытаясь произвести округление с помощью формата числа.

Формат никак не влияет на точность числа в ячейке. Поэтому не стоит надеяться на формат, когда нужно реальное округление.

Функция ОКРУГЛ в Excel

Для обычного округления числа по математическим правилам существует функция ОКРУГЛ, которая имеет следующий синтаксис:

ОКРУГЛ(число или ссылка на округляемое число; количество оставляемых знаков).

число или ссылка на округляемое число – исходное число для округления;

количество оставляемых знаков – количество знаков после запятой.

Например, формула округления в Excel до двух знаков после запятой выглядит так.

Чтобы получить формулу округления в Excel до целого числа, во втором аргументе нужно поставить 0.

Встречаются и более сложные ситуации. Как, например, округлить до тысяч (три последние цифры являются нулями)? Многие поступают так. Делят число на 1 000, округляют до целого и затем снова умножают на 1 000. Это не лучший способ.

Функция ОКРУГЛ умеет округлять не только после запятой, но и до запятой, т.е. до тысяч, миллионов и т.д. Например, чтобы число 123456789 округлить до тысяч и получить 123457000, точность указывается с минусом.

На этом формулы округления в Эксель не заканчиваются.

ОКРУГЛВВЕРХ и ОКРУГЛВНИЗ

В Excel есть формулы округления в большую и меньшую сторону независимо от последних цифр числа. Например, расчетные цены округляют вверх, чтобы не уменьшить прибыль; возраст человека округляют вниз до целого, чтобы узнать полное количество лет. Короче, для этих целей придуманы функции ОКРУГЛВВЕРХ и ОКРУГЛВНИЗ.

Данные функции имеют такие же параметры, как и ОКРУГЛ (ссылка на число и количество знаков до или после запятой).

ОКРУГЛТ

Довольно полезная функция ОКРУГЛТ. С ее помощью можно добиться округления не только до нужного разряда (слева или справа от запятой), но и вообще до нужной точности (кратности). К примеру, нужно рассчитать заказ изделий в штуках, но так, чтобы он был равен целому количеству ящиков. Если в ящике 6 шт, то заказываемое количество должно быть кратно шести. Или другой пример. Нужно, чтобы расчетная цена заканчивалась либо на 00, либо на 50, то есть имела кратность 50 рублей. Функция ОКРУГЛТ легко решает такие задачи.

Очень, очень правильная функция. Позволяет избежать 3-х промежуточных расчетов (разделить на кратность, округлить до целого и снова умножить на кратность, как я сам делал, пока не узнал про эту формулу).

ОКРВВЕРХ.МАТ и ОКРВНИЗ.МАТ

Округление с заданной точностью также можно производить принудительно вверх или вниз с помощью ОКРВВЕРХ.МАТ и ОКРВНИЗ.МАТ. Например, при расчете заказа, когда никак нельзя заказать меньше расчетного объема, но при этом нужно и кратность сохранить. То есть одна «лишняя» штука требует заказа дополнительно целого ящика. Аргументы функции те же.

Это были основные формулы округления в Excel. Но есть еще парочку, которые используются реже.

Функция ЦЕЛОЕ в Excel отбрасывает дробную часть и таким образом округляет вниз до ближайшего целого. Будет полезна при расчете целого количество лет между датами (возраст человека).

Функции ЧЁТН и НЕЧЁТ округляют числа до ближайшего четного или нечетного значения соответственно.

Видеоуроки ниже показываю основные приемы округления, а также некоторые трюки.



Округление в Excel. Пошаговая инструкция

Округление чисел в Excel нужно для удобного форматирования, прогнозирования и коммуникации.

Существует множество способов округления, такие как округление до целого числа, округление в большую сторону, округление в меньшую сторону и т.д. В Excel мы можем округлять числа с помощью функций. Их мы и рассмотрим в этой статье.

Округление чисел в Excel с помощью изменения формата ячейки

Если вы хотите округлить числа исключительно с целью презентации, вы можете изменить формат ячейки, выполнив следующие шаги:

  • Кликнуть по ячейке с числовым значением;
  • Открыть меню форматирования ячейки с помощью сочетания клавиш CTRL+1 или кликнуть по ячейке правой кнопкой и в выпадающем списке выбрать пункт “ Формат ячеек “;
  • В всплывающем окне “ Формат ячеек ” перейти на вкладку “ Число “;
  • В разделе “ Числовые форматы ” кликнуть по пункту “ Числовой “;
  • В меню окна найти пункт “ Число десятичных знаков ” и указать точное количество знаков после запятой, которое вы хотите оставить;
  • Кликните по кнопке “ ОК ” для сохранения настроек форматирования.

Важно! Этот метод только визуально округляет число, не “отрезая” числа после запятой.

Округление в Excel с помощью функции ОКРУГЛ

Функция ОКРУГЛ часто используется в Excel для округления чисел. С ее помощью вы можете задать количество чисел после запятой.

Читать еще:  Создание шаблона в word 2020

Синтаксис

=ОКРУГЛ(число;число_разрядов)

Аргументы функции

  • число – числовое значение, которое вы хотите округлить;
  • число_разрядов – значение десятичного разряда, до которого вы хотите округлить первый аргумент функции.

Основы использования функции

  • если аргумент число_разрядовбольше “0”, то число округляется до указанного количества десятичных знаков. Например, =ОКРУГЛ(500,51;1) вернет “500.5”;
  • если аргумент число_разрядов равен “0”, то число округляется до ближайшего целого числа. Например, =ОКРУГЛ(500,51;0) вернет “501”;
  • если аргумент число_разрядовменьше “0”, то число округляется влево от десятичного значения. Например, =ОКРУГЛ(500,51;-1) вернет “501”.

Функция ОКРУГЛ работает на основе математического правила, по которому она определяет в большую или меньшую сторону следует округлить число:

  • Если число после запятой равно от 0 до 4, то округление будет произведено в меньшую сторону;
  • Если число после запятой равно от 5 до 9, то функция округлит в большую сторону.

На скриншоте ниже показаны примеры использования функции:

Округление в Excel в большую сторону с помощью функции ОКРУГЛВВЕРХ

Функция ОКРУГЛВВЕРХ округляет число в большую сторону, вне зависимости от того, какое число стоит после запятой.

Синтаксис

=ОКРУГЛВВЕРХ(число;число_разрядов)

Аргументы функции

  • число – числовое значение, которое вы хотите округлить;
  • число_разрядов – значение десятичного разряда, до которого вы хотите округлить первый аргумент функции.

Примеры использования функции ниже:

Округление в Excel в меньшую сторону с помощью функции ОКРУГЛВНИЗ

Функция ОКРУГЛВНИЗ округляет число в меньшую сторону, вне зависимости от того, какое число стоит после запятой.

Синтаксис

=ОКРУГЛВВНИЗ(число;число_разрядов)

Аргументы функции

  • число – числовое значение, которое вы хотите округлить;
  • число_разрядов – значение десятичного разряда, до которого вы хотите округлить первый аргумент функции.

На скриншоте ниже примеры использования функции:

Правильно округляем в Microsoft Excel

При повседневной работе с приложением Excel часто возникает необходимость в округлении значений, однако при применении нестандартных средств это может привести к серьезным ошибкам в вычислениях.

Округление значений и связанные с этим ошибки в вычислениях зачастую имеют место при повседневной работе в Excel. Несмотря на небольшую разницу, неприятно, когда в общем итоге не хватает нескольких копеек или сумма процентов в колонке составляет 101.

При финансовых расчетах важно округлять до правильного знака после запятой. К примеру, если цена нетто составляет 1,99 рубля или гривны, а стоимость брутто рассчитывается как 2,3681, то общая цена ста единиц товара никогда не будет равняться 236,81 рубля (гривны). Все иначе с расценками на бензин: здесь уже имеют значение три последние цифры.

Разнообразие функций программы

Excel знает 15 различных функций округления: «ОКРУГЛ», «ОКРУГЛВВЕРХ», «ОКРУГЛВНИЗ», «ОКРУГЛТ», «ОКРВНИЗ», «ОКРВВЕРХ», «ОКРВВЕРХ.ТОЧН», «ОКРВНИЗ.ТОЧН», «ОТБР.РУБЛЬ» и «ФИКСИРОВАННЫЙ». Вместо одной специальной функции лучше использовать привычную с дополнительным вычислением или с правильным параметром. Проблемы вызывают функции «ОКРУГЛВВЕРХ» и «ОКРУГЛВНИЗ», которые выдают неочевидные результаты при использовании отрицательных чисел. Например, «=ОКРУГЛВВЕРХ (–2,5;0)» выдает значение «–3» вместо «–2». Для таких случаев рекомендуем использовать функции «ОКРВВЕРХ» и «ОКРВНИЗ».

Второе число — это параметр. Однако он сообщает не количество знаков после запятой, а кратное, необходимое для округления. Для двух десятичных знаков используйте кратное «0,01». Вы можете гибко округлять и до других кратных. Основа для пени за просрочку выплаты налогов будет округляться до следующей суммы, кратной рублю (гривне) в большую сторону. Подобных результатов можно добиться и с помощью функции «ОКРУГЛТ».

Математическое округление

Стандартное «ОКРУГЛ» в Excel использует математическое округление, то есть округляет числа, заканчивающиеся на «5», в большую сторону. В некоторых случаях это недопустимо — например, в бухгалтерии при суммировании округляемых цифр. Избежать ошибок позволит созданная в VBA функция с гауссовым округлением — до ближайшего четного числа. Для ее программирования с именем «MATHROUND» откройте редактор VBA комбинацией клавиш «Alt+F11». Введите следующий код:

Function•MathRound(ByVal•X•As•Double, Optional•Factor•As•Long•=•0)
MathRound •=•Round(X,•Factor)
End•Function

Закройте редактор VBA. Теперь в таблице можно будет использовать для гауссова («банковского») округления вместо «ОКРУГЛ» функцию «MATHROUND».

Как это сделать?

1. НАСТРАИВАЕМ ФОРМАТ Для наглядности расчетов вы используете значения, округленные до двух знаков после запятой. Зачастую настройка числового формата подходит лучше, чем преждевременное применение функции округления.

2. ПРЕДСТАВЛЕНИЕ ОКРУГЛЕНИЯ Для этого используйте быстрое форматирование на вкладке «Главная» в разделе «Число». Кликните по стрелке в нижней части раздела и в открывшемся окне на вкладке «Число» задайте число знаков после запятой для параметров «Числовой», «Денежный», «Финансовый» или «Процентный».

3. ОПАСНАЯ ОПЦИЯ Откройте «Файл | Параметры» и выберите категорию «Дополнительно». Убедитесь, что в разделе «При пересчете этой книги» опция «Задать точность как на экране» отключена.

4. ВВЕРХ И ВНИЗ Функции «ОКРУГЛВВЕРХ» и «ОКРУГЛВНИЗ» то и дело округляют сумму до нуля, что для отрицательных чисел неверно с математической точки зрения. Лучше использовать «ОКРВВЕРХ» и «ОКРВНИЗ».

5. ДРУГАЯ ОСНОВА Для округления на другой основе, к примеру, 5 копеек, используйте вычисление или — для положительных значений — сразу функцию «=ОКРУГЛ(число; 0,05)».

6. ПРОБЛЕМА НЕПРАВИЛЬНЫХ СУММ При разбивке сумм порой возникают небольшие ошибки, а Excel округляет чаще вверх, чем вниз. Во избежание бухгалтерских ошибок вычисляйте последнюю часть суммы как разницу к общей сумме.

7. ГАУССОВО ОКРУГЛЕНИЕ Функция «ОКРУГЛ» использует математическое округление, и результаты зачастую искажены. Гауссово («банковское») округление «MATHROUND» из VBA предотвратит это.

8. НЕРАВНЫЕ ПАРЫ Одинаковые значения вследствие неточностей вычисления и округления иногда выглядят разными. Желаемых результатов можно добиться с помощью правильного округления.

Ссылка на основную публикацию
Adblock
detector