Letysite.ru

IT Новости с интернет пространства
0 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Unable to locate package linux headers

Устранение ошибки «E: Unable to locate package» на Ubuntu

Туториал для новичков: как избавиться от ошибки «E: Unable to locate package» на Linux Ubuntu.

Tatiana Yaroshenko

Read more posts by this author.

Tatiana Yaroshenko

Туториал для новичков: как избавиться от ошибки «E: Unable to locate package» на Linux Ubuntu.

Команда apt или apt-get — один из способов установки ПО на Ubuntu. В терминале после команды прописывается название программы, которую нужно установить.

Иногда в процессе установки происходит сбой. Уведомление выглядит следующим образом:

Текст ошибки говорит сам за себя. Система не может найти пакеты, которые вы пытаетесь установить. Почему это происходит?

Устранение ошибки «Unable to locate package» на Ubuntu

Шаг за шагом рассмотрим, что могло пойти не так.

1. Имя пакета

Это нужно проверить в первую очередь. Возможно, в название закралась опечатка. Если нужно установить «vlc», а в команде прописано «vcl», то, вполне естественно, процесс прервётся.

2. Обновление кэша репозитория

Во время первого старта системы необходимо запустить обновление при помощи следующей команды:

Эта команда не будет сразу же обновлять Ubuntu. Она предназначена для обновления информации о пакетах, содержащихся в репозиториях.

Когда запускается команда установки, apt-менеджер находит в кэше информацию о пакете и его версии, после чего загружает файлы через репозиторий. Соответственно, если пакета нет в кэше, появится уведомление об ошибке.

Сразу после установки новой системы, её кэш еще пуст. Именно поэтому в таких случаях необходимо прописать команду обновления как для Ubuntu, так и для любого другого дистрибутива на её основе (например, Linux Mint) во время первого запуска.

Но даже при работе с давно установленной системой есть шанс, что нужный пакет не был подгружен. Чтобы исключить такую вероятность, стоит перестраховаться и обновить кэш.

3. Доступен ли пакет для используемой версии Ubuntu

Итак, название написано правильно, кэш обновлён, но ошибка всё равно появляется.

Вероятно, пакет доступен через репозиторий Universe, а ваша система или не поддерживает его, или версия Ubuntu не поддерживается данной программой.

Шаг первый – проверить актуальную версию Ubuntu через терминал.

На выходе отображается номер версии и кодовое имя.

Например, версия Ubuntu 18.04 c кодовым именем “bionic”.

Шаг второй – расширенный поиск на сайте пакетов Ubuntu.

На сайте доступна опция поиска по ключевому слову. Вводим название пакета и выставляем кодовое имя дистрибутива. В графе ”секция” нужно выставить значение ”any”. Запускаем поиск.

Так можно узнать, доступен ли пакет для конкретной версии Ubuntu и, если доступен, то к какому репозиторию он относится. Разберём на примере Shutter, программы для создания скриншотов, которую не обновляли в течение последних лет. Для версии Ubuntu18.04 Bionic будут выведены следующие данные.

В этом случае есть точное совпадение с названием пакета. Он доступен для версии Ubuntu 18.04 Bionic и относится к репозиторию Universe.

Если искомый пакет доступен для вашей версии системы, но относится к Universe или Multiverse, необходимо установить дополнительные репозитории.

После этого обновите кэш, чтобы убедиться, что пакеты доступны через репозитории.

Ничего не помогло, что делать?

Если пакет недоступен и на сайте Ubuntu, то нужно искать другой способ установки. Усилиями сторонних разработчиков были созданы персональные архивы пакетов (PPA). Здесь стоит быть осторожными с неофициальными архивами и не добавлять сомнительные версии в систему.

Если этот способ не сработал, можно посетить официальный сайт проекта и уточнить, есть ли альтернативные способы установки их программ. На некоторых ресурсах доступны .DEB или AppImage файлы. Какие-то проекты могли перейти на пакеты Snap.

Всегда есть вероятность, что проект был закрыт и более не поддерживается. В таком случае выход один: искать альтернативу самой программе.

Ошибка unable to locate package в Ubuntu

Один из многих способов установки программного обеспечения в Ubuntu – команда apt-get или apt. Установка пакетов с помощью пакетного менеджера намного удобнее и безопаснее, чем поиск и загрузка программ в интернете. Открыв терминал, вы должны вызвать утилиту apt с параметром install написать название программы, чтобы установить ее.

При использовании этой команды иногда возникает ошибка E: Unable to locate package. Ошибка не нуждается в пояснении. Linux-система не может найти пакет, который вы пытаетесь установить. Но почему так? Почему она не видит пакет? Рассмотрим несколько способов решения данной проблемы. В этой статье мы рассмотрим как исправить ошибку Unable to locate package error в Ubuntu.

Ошибка Unable to locate package error в Ubuntu

Дальше пошагово рассмотрим процесс устранения ошибки.

1. Проверьте имя пакета

Это первое, что вы должны сделать. Может, в названии пакета опечатка? Если вы пытаетесь установить vlc и написали vcl, то непременно ничего не получится. Опечатки – распространенная проблема, так что убедитесь в том, что вы не допустили ошибок во время ввода имени пакета.

2. Обновите кэш репозиториев

Если вы в первый раз запустили систему после установки, следует написать команду update:

sudo apt update

Данная команда не обновит Ubuntu полностью. На деле, команда apt update составляет локальный список доступных для установки пакетов.

При использовании команды install, менеджер пакетов apt просматривает кэш, чтобы получить информацию о пакете и его версии, а затем скачать его из репозиториев в сети. Если пакета в кэше нет, система не сможет его установить.

Кэш в только что установленной системе изначально пуст. Именно поэтому вам стоит запустить команду apt update сразу после установки Ubuntu или других дистрибутивов, основанных на Ubuntu (например, Linux Mint).

Читать еще:  Itunes ошибка 4013 при восстановлении

Даже если система не новая, кэш apt вполне может оказаться устаревшим. В любой момент не лишним будет его обновить.

3. Убедитесь, что пакет доступен в вашей версии Ubuntu

Отлично! Вы проверили название пакета, и оно верно. Вы запустили команду update, чтобы обновить состояние кэша, но все ошибка unable to locate package все еще присутствует. Вполне возможно, что пакет попросту недоступен. Но вы следуете инструкции с какого-то сайта, и у всех получается установить его указанным образом. В чем может заключаться проблема?

Есть два варианта. Либо пакет доступен в репозитории Universe, который в вашей системе не включен, либо пакета вовсе не существует для вашей версии Ubuntu.

Первый шаг – проверьте, какая версия Ubuntu у вас запущена. Откройте терминал и введите следующую команду:

В результате вы увидите версию Ubuntu и ее кодовое название. Именно кодовое название нам важно больше всего. Как видите, мы используем Ubuntu 18.04 с кодовым именем bionic. У вас может быть иначе, но суть должна быть понятна. Как только вы получили сведения о версии и названии, откройте сайт Ubuntu Packages.

Пролистайте пониже и остановитесь на заголовке Поиск. Вы увидите поле с ключевым словом. Введите название пакета, который ваша система не может найти, и выберите соответствующее кодовое имя. Секцию поставьте любую. После проделанных действий, нажмите на кнопку поиска.

Вам будет показано, доступен ли пакет для вашей версии Ubuntu, и если это так, то вместе с этим отобразится репозиторий, в котором он находится. Мы искали средство создания скриншотов Shutter и вот, что вышло для Ubuntu 18.04 Bionic:

В нашем случае, название пакета точно совпало. Это значит, что пакет shutter существует для Ubuntu 18.04 Bionic, но в репозитории Universe.

Если необходимый пакет доступен для вашей версии Ubuntu, но в Universe или Multiverse, эти репозитории необходимо включить:

sudo add-apt-repository universe multiverse

Также нужно обновить кэш для того, чтобы система узнала о новых пакетах, находящихся в подключенных репозиториях:

sudo apt update

Теперь установка пакета должна пройти гладко.

Ничего не работает, что делать?

Если сайте Ubuntu Packages показывает, что пакета для вашей версии системы нет, то придется найти обходные пути его установки.

Возьмем в качестве примера Shutter. Это отличное средство создания скриншотов для Linux, но его несколько лет не обновляли, поэтому в Ubuntu 18.10 и более новых версиях оно не поддерживается. Как же его установить? К счастью, один сторонний разработчик создал собственный репозиторий (PPA) и установить программу можно с помощью него. Искать пакеты и PPA, в которых они находятся, можно на сайте Launchpad для Ubuntu.

Учтите, что не стоит подключать неофициальные PPA к списку репозиториев. Лучше пользоваться теми, которые есть в вашем дистрибутиве.

Если нет даже PPA, зайдите на официальный сайт программы и проверьте, нет ли там описания альтернативных способов установки. У некоторых проектов есть .deb или AppImage файлы. Другие перешли на Snap пакеты.

Иными словами, проверьте на официальном сайте, не изменился ли метод установки приложения.

Если ничего не помогло, есть вероятность, что проект уже не поддерживают, и в таком случае придется поискать программе замену.

В заключение…

Теперь вы знаете как исправить ошибку unable to locate package Ubuntu. Если вы начали пользоваться Linux недавно, все может казаться очень непонятным. По этой причине мы освещаем подобные темы, чтобы вы могли лучше разобраться в том, как работают те или иные аспекты вашей системы.

Надеемся, что это руководство помогло решить проблему с пакетами в Ubuntu. Если у вас есть вопросы или предложения, можно оставить их в комментариях.

How to Install Kernel Headers in Ubuntu and Debian

by Aaron Kili | Published: May 19, 2018 | May 19, 2018

In our last article, we have explained how to install kernel headers in CentOS 7. Kernel Headers contain the C header files for the Linux kernel, which offers the various function and structure definitions required when compiling any code that interfaces with the kernel, such as kernel modules or device drivers and some user programs.

It is very important to note that the kernel headers package you install should match with the currently installed kernel version on your system. If your kernel version ships with the default distribution installation or you have upgraded your Kernel using dpkg or apt package manager from the Ubuntu or Debian base repositories, then you must install matching kernel headers using package manager only. And if you’ve compiled kernel from sources, you must also install kernel headers from sources.

In this article, we will explain how to install Kernel Headers in Ubuntu and Debian Linux distributions using default package manager.

Install Kernel Headers in Ubuntu and Debian

First check your installed kernel version as well as kernel header package that matches your kernel version using following commands.

Check Kernel Version and Kernel Headers in Ubuntu

On Debian, Ubuntu and their derivatives, all kernel header files can be found under /usr/src directory. You can check if the matching kernel headers for your kernel version are already installed on your system using the following command.

Check Kernel Headers in Ubuntu

From the above output, it’s clear that the matching kernel header directory doesn’t exist, meaning the package is not yet installed.

Читать еще:  Auepuc exe системная ошибка

Before you can install the appropriate kernel headers, update your packages index, in order to grab information about the latest package releases, using the following command.

Then run the following command that follows to install the Linux Kernel headers package for your kernel version.

Install Kernel Headers in Ubuntu

Next, check if the matching kernel headers have been installed on your system using the following command

Verify Installed Kernel Headers in Ubuntu

That’s all! In this article, we have explained how to install kernel headers in Ubuntu and Debian Linux and other distributions in the Debian family tree.

Always keep in mind that to compile a kernel module, you will need the Linux kernel headers. If you have any quires, or thoughts to share, use the comment form below to reach us.

Устранение ошибки «E: Unable to locate package» на Ubuntu

Туториал для новичков: как избавиться от ошибки «E: Unable to locate package» на Linux Ubuntu.

Tatiana Yaroshenko

Read more posts by this author.

Tatiana Yaroshenko

Туториал для новичков: как избавиться от ошибки «E: Unable to locate package» на Linux Ubuntu.

Команда apt или apt-get — один из способов установки ПО на Ubuntu. В терминале после команды прописывается название программы, которую нужно установить.

Иногда в процессе установки происходит сбой. Уведомление выглядит следующим образом:

Текст ошибки говорит сам за себя. Система не может найти пакеты, которые вы пытаетесь установить. Почему это происходит?

Устранение ошибки «Unable to locate package» на Ubuntu

Шаг за шагом рассмотрим, что могло пойти не так.

1. Имя пакета

Это нужно проверить в первую очередь. Возможно, в название закралась опечатка. Если нужно установить «vlc», а в команде прописано «vcl», то, вполне естественно, процесс прервётся.

2. Обновление кэша репозитория

Во время первого старта системы необходимо запустить обновление при помощи следующей команды:

Эта команда не будет сразу же обновлять Ubuntu. Она предназначена для обновления информации о пакетах, содержащихся в репозиториях.

Когда запускается команда установки, apt-менеджер находит в кэше информацию о пакете и его версии, после чего загружает файлы через репозиторий. Соответственно, если пакета нет в кэше, появится уведомление об ошибке.

Сразу после установки новой системы, её кэш еще пуст. Именно поэтому в таких случаях необходимо прописать команду обновления как для Ubuntu, так и для любого другого дистрибутива на её основе (например, Linux Mint) во время первого запуска.

Но даже при работе с давно установленной системой есть шанс, что нужный пакет не был подгружен. Чтобы исключить такую вероятность, стоит перестраховаться и обновить кэш.

3. Доступен ли пакет для используемой версии Ubuntu

Итак, название написано правильно, кэш обновлён, но ошибка всё равно появляется.

Вероятно, пакет доступен через репозиторий Universe, а ваша система или не поддерживает его, или версия Ubuntu не поддерживается данной программой.

Шаг первый – проверить актуальную версию Ubuntu через терминал.

На выходе отображается номер версии и кодовое имя.

Например, версия Ubuntu 18.04 c кодовым именем “bionic”.

Шаг второй – расширенный поиск на сайте пакетов Ubuntu.

На сайте доступна опция поиска по ключевому слову. Вводим название пакета и выставляем кодовое имя дистрибутива. В графе ”секция” нужно выставить значение ”any”. Запускаем поиск.

Так можно узнать, доступен ли пакет для конкретной версии Ubuntu и, если доступен, то к какому репозиторию он относится. Разберём на примере Shutter, программы для создания скриншотов, которую не обновляли в течение последних лет. Для версии Ubuntu18.04 Bionic будут выведены следующие данные.

В этом случае есть точное совпадение с названием пакета. Он доступен для версии Ubuntu 18.04 Bionic и относится к репозиторию Universe.

Если искомый пакет доступен для вашей версии системы, но относится к Universe или Multiverse, необходимо установить дополнительные репозитории.

После этого обновите кэш, чтобы убедиться, что пакеты доступны через репозитории.

Ничего не помогло, что делать?

Если пакет недоступен и на сайте Ubuntu, то нужно искать другой способ установки. Усилиями сторонних разработчиков были созданы персональные архивы пакетов (PPA). Здесь стоит быть осторожными с неофициальными архивами и не добавлять сомнительные версии в систему.

Если этот способ не сработал, можно посетить официальный сайт проекта и уточнить, есть ли альтернативные способы установки их программ. На некоторых ресурсах доступны .DEB или AppImage файлы. Какие-то проекты могли перейти на пакеты Snap.

Всегда есть вероятность, что проект был закрыт и более не поддерживается. В таком случае выход один: искать альтернативу самой программе.

проблема с linux-headers

Привет сообществу! Столкнулся с проблеммой обновления linux-headers-4.14.0-kali3-amd64 и не могу продолжить установку видеодрайверов из за этого. Вывод после команды apt-get install linux-headers-$(uname -r) таков:

Есть мысли по решение этой задачи, ребята?

A na koy xep tebe video na kali? 🙂

apt update сделал? Если да то, значит в соурс листе проблемы.

Посомтри какая версия ядра ясть в репозитории, установи её, а затем установи linux-headers под него.

apt-get update делали?

Вот он — дебиан во всей красе!

Этот дебиан уже не дебиан.

Где здесь дебиан?

oснована на Debian

Вот в этом то все и дело что версия ядра у меня последняя:

Все делали дорогой.

Покажи вывод apt list linux-headers*, возможно так префиксы есть.

Читать еще:  Удаленный доступ linux

Столкнулся с проблеммой обновления linux-headers-4.14.0-kali3-amd64 и не могу продолжить установку видеодрайверов из за этого

Ты имеешь ввиду, что linux-headers у тебя уже стоит, но не хочет обновлятся?

естественно дебиан виноват — а не говноподелия рукожопых калийщиков.

версия ядра у меня последняя

нет таких версий — дурацкие названия во время компиляции можно разные придумать.

нет таких версий — дурацкие названия во время компиляции можно разные придумать.

Откуда такая ненависть к Kali? Узкоспециализированная вещь и все тут

Cразу оговорюсь — заголовки 4.15.11 установил сам. По незнанию думал они сгодятся. Но они не сгодятся ((

Как видим никакие не установлены

Выходит у тебя ядро Linux kali 4.14.0-kali3-amd64, а headers 4.15.0-kali2. После обновления перезагружался? Если да, то видимо какие-то проблемы с репами. Попробуй нагуглить sources.list для kail и сравнить со своим.

нет никакой специализации — очередное поделие на базе дебиана дескридитирующая его своей рукожопостью порождает такие выперлы

Вот он — дебиан во всей красе!

нет что б взять годный родной дебиан и на основе базовой части собрать из репы узкоспециализированное для себя любимого, зачем — берем готовую залипуху и хаем дебиан

Покажи еще apt list linux* (или apt list kernel*), посмотрим, установелено ли у тебя ядро 4.15.

Как ты определил, что у тебя последнее ядро?

c репами все впорядке. Там одна запись всего.

это не дебиан. это неосилятор во всей красе. школота начиталась про «хакерский дистрибутив» и заваливает ЛОР тупыми вбросами.

кали — это не рабочий дистрибутив для десктопа. это тестовая сборка для выполнения penetration tests. больше она ни для чего не пригодна.

давай вывод apt list linux* (или apt list kernel, если пусто будет), нужно посмотреть какие ядра есть в репах и какие установлены. Есть еще apt policy linux, но он вроде не показывает установленные пакеты — только версии.

Поставь последнее ядро и Linux-headers под него.

После чего тему закрой.

Как определил что последнее ядро!? А вот команда

кали — это не рабочий дистрибутив для десктопа. это тестовая сборка для выполнения penetration tests. больше она ни для чего не пригодна.

Мы знаем бабуль, мы знаем. Я «школота-веб разработчик», делаю сайтики. Нужно протестировать форму входа на сайт. Клиент хочет надежную форму. Вот и стараюсь.

нашел и скачал подходящую версию. Но что то не получается установить. Пробовал так:

И вот так пробовал:

РЕШЕНО

Получилось. Забыл что у меня grub от Fedora 27 стоит. (Вторая система на ноуте). После его обновления все ядра нашлись. Итог. Что мы имеем:

Который не может ядро поставить, не верю. Да и зачем вообще этот дистр. устанавливать, записал на флешку. И все на куй он больше не сдался.

Привёл список пактов я ядром в репозитории Kali, в котором ясно видно, что последнее ядро в нём «kernel-image-4.15.0-kali2-amd64-di_4.15.11-1kali1_amd64.udeb»

нашел и скачал подходящую версию. Но что то не получается установить. Пробовал так:

Всё надо ставить из репозитория

И вот так пробовал:

Вот так и надо было делать с самого начала.

Забыл что у меня grub от Fedora 27 стоит

Это уже твои проблемы, что ты не указали данные в теме.

А так, тебе сразу я написал, что у тебя стоит не последнее ядро, значит нужно поискать по репозиторию и поставить, а не плодить кучу ненужной информации в теме.

В Debian пакет с ядром называется kernel-image, а не linux-image, тут я ошибся, но ты должен и самостоятельно пытаться найти информацию и разобраться как делать поиск по репозиторию и как называются пакеты с ядром.

Пожалуйста, используй голову не только для ношения шапки, а по прямому назначению.

внучек, дык на какого фейхоа тебе видеодрайверы для этого, ась? тем более самосборные.

веб — это веб. не лезь ты к системе ради макаронного монстра.

внучек, дык на какого фейхоа тебе видеодрайверы для этого, ась? тем более самосборные.

Вот, бабушка, хаять хаем Kali, а в системе на разбираемся. Это типа как — Пастернака не читал но осуждаю! Видеодрайвера нужны для работы 3D-ускорения и поддержки таких инструментов как Hashcat, например. Хочу попробовать брутфорса атаку не только ресурсами процессора но и видеокарту подключить к перебору. Скорость больше а значит быстрее подборо пойдет.

Понял, обязательно учту критику. Она имеет место быть. Новичек в Linux. Чуть больше месяца сижу. Пока опыта мало вот и обращаюсь к более знающим.
Так что не суди строго bro

Вот, бабушка, хаять хаем Kali, а в системе на разбираемся. Это типа как — Пастернака не читал но осуждаю! Видеодрайвера нужны для работы 3D-ускорения и поддержки таких инструментов как Hashcat, например. Хочу попробовать брутфорса атаку не только ресурсами процессора но и видеокарту подключить к перебору. Скорость больше а значит быстрее подборо пойдет.

понятно. то есть, ламерство ещё и в вебе. если на вашем сайтике ещё и брутфорс возможен — поздравляю. ладно, проехали. мне скучна пионерия.

мы все уже поняли что ты очень важна и авторитетна. Жаль только пользы от твоих коментов не много. «100 лет в программировании» и важности полные трусы которую нужно всем показать обязательно. Так и помрешь со своими «знаниями» глобальными)

каков вопрос — таков ответ. как-то так. тут часто пионерия вопрошает вещи, которые гуглятся за пять минут. так вот: пусть учатся гуглить.

Ссылка на основную публикацию
Adblock
detector