Letysite.ru

IT Новости с интернет пространства
0 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Округление в меньшую сторону excel

Округление чисел в Excel

Мы часто сталкиваемся с вопросом как сделать округление в Excel, поэтому давайте разберем основные способы округления числа (в большую, в меньшую сторону, до целого числа и т.д.).

Округление чисел по разрядам в Excel

В Excel есть стандартная функция ОКРУГЛ, которая позволяет округлить число по количеству разрядов:

ОКРУГЛ(число; число_разрядов)
Округляет число до указанного количества десятичных разрядов.

  • Число(обязательный аргумент) — округляемое число;
  • Число разрядов(обязательный аргумент) — количество разрядов для округления.

Пример использования формулы ОКРУГЛ

Округление числа в большую сторону в Excel

В случае если необходимо округлить число в большую сторону, то можно воспользоваться формулой ОКРУГЛВВЕРХ:

ОКРУГЛВВЕРХ(число; число_разрядов)
Округляет число до ближайшего большего по модулю.

Аргументы функции такие же как и в формуле ОКРУГЛ.

Пример использования формулы ОКРУГЛВВЕРХ

Округление числа в меньшую сторону в Excel

Аналогом для округления числа в меньшую сторону является функция ОКРУГЛВНИЗ:

ОКРУГЛВНИЗ(число; число_разрядов)
Округляет число до ближайшего меньшего по модулю.

Пример использования формулы ОКРУГЛВНИЗ

Округление до целого числа в Excel

Для того, чтобы округлить число до целого можно воспользоваться функциями ОКРУГЛ, ОКРУГЛВВЕРХ, ОКРУГЛВНИЗ, приняв аргумент функции число_разрядов равным нулю, т.е. другими словами, округлить число до 0 знаков после запятой, что равносильно округлению до целого числа:

Пример округления до целого числа

Также в Excel есть группа функций, которая позволяет округлять число с определенной кратностью, в частности, в случае округления в большую сторону можно воспользоваться функцией ОКРВВЕРХ:

ОКРВВЕРХ(число; точность)
Округляет число до ближайшего целого или до ближайшего кратного указанному значению.

  • Число(обязательный аргумент) — округляемое число;
  • Точность(обязательный аргумент) — кратное, до которого округляется число.

В нашем случае мы задаем точность равной 1, иными словами, округляем до числа кратного 1:

Пример использования формулы ОКРВВЕРХ

ОКРВНИЗ(число; точность)
Округляет число до ближайшего меньшего по модулю целого.

Округление в Excel. Пошаговая инструкция

Округление чисел в Excel нужно для удобного форматирования, прогнозирования и коммуникации.

Существует множество способов округления, такие как округление до целого числа, округление в большую сторону, округление в меньшую сторону и т.д. В Excel мы можем округлять числа с помощью функций. Их мы и рассмотрим в этой статье.

Округление чисел в Excel с помощью изменения формата ячейки

Если вы хотите округлить числа исключительно с целью презентации, вы можете изменить формат ячейки, выполнив следующие шаги:

  • Кликнуть по ячейке с числовым значением;
  • Открыть меню форматирования ячейки с помощью сочетания клавиш CTRL+1 или кликнуть по ячейке правой кнопкой и в выпадающем списке выбрать пункт “ Формат ячеек “;
  • В всплывающем окне “ Формат ячеек ” перейти на вкладку “ Число “;
  • В разделе “ Числовые форматы ” кликнуть по пункту “ Числовой “;
  • В меню окна найти пункт “ Число десятичных знаков ” и указать точное количество знаков после запятой, которое вы хотите оставить;
  • Кликните по кнопке “ ОК ” для сохранения настроек форматирования.

Важно! Этот метод только визуально округляет число, не “отрезая” числа после запятой.

Округление в Excel с помощью функции ОКРУГЛ

Функция ОКРУГЛ часто используется в Excel для округления чисел. С ее помощью вы можете задать количество чисел после запятой.

Синтаксис

=ОКРУГЛ(число;число_разрядов)

Аргументы функции

  • число – числовое значение, которое вы хотите округлить;
  • число_разрядов – значение десятичного разряда, до которого вы хотите округлить первый аргумент функции.

Основы использования функции

  • если аргумент число_разрядовбольше “0”, то число округляется до указанного количества десятичных знаков. Например, =ОКРУГЛ(500,51;1) вернет “500.5”;
  • если аргумент число_разрядов равен “0”, то число округляется до ближайшего целого числа. Например, =ОКРУГЛ(500,51;0) вернет “501”;
  • если аргумент число_разрядовменьше “0”, то число округляется влево от десятичного значения. Например, =ОКРУГЛ(500,51;-1) вернет “501”.

Функция ОКРУГЛ работает на основе математического правила, по которому она определяет в большую или меньшую сторону следует округлить число:

  • Если число после запятой равно от 0 до 4, то округление будет произведено в меньшую сторону;
  • Если число после запятой равно от 5 до 9, то функция округлит в большую сторону.

На скриншоте ниже показаны примеры использования функции:

Округление в Excel в большую сторону с помощью функции ОКРУГЛВВЕРХ

Функция ОКРУГЛВВЕРХ округляет число в большую сторону, вне зависимости от того, какое число стоит после запятой.

Синтаксис

=ОКРУГЛВВЕРХ(число;число_разрядов)

Аргументы функции

  • число – числовое значение, которое вы хотите округлить;
  • число_разрядов – значение десятичного разряда, до которого вы хотите округлить первый аргумент функции.

Примеры использования функции ниже:

Округление в Excel в меньшую сторону с помощью функции ОКРУГЛВНИЗ

Функция ОКРУГЛВНИЗ округляет число в меньшую сторону, вне зависимости от того, какое число стоит после запятой.

Синтаксис

=ОКРУГЛВВНИЗ(число;число_разрядов)

Аргументы функции

  • число – числовое значение, которое вы хотите округлить;
  • число_разрядов – значение десятичного разряда, до которого вы хотите округлить первый аргумент функции.

На скриншоте ниже примеры использования функции:

Как округлять числа в Excel

В статье рассмотрено, как округлить число в Excel с помощью различных функций, таких как ОКРУГЛ, ОКРУГЛВНИЗ, ОКРУГЛВВЕРХ и другие методы округления. Также приведены примеры формул, как округлить до целого числа, до десятых, до тысяч, до 5, 10 или 100, как округлить кратному числу, а также много других примеров.

Читать еще:  Как закрепить область в excel 2020

Округлить число в путем изменения формата ячейки

Если вы хотите округлить числа в Excel исключительно для визуальной презентации, вы можете изменить формат ячейки, выполнив следующие шаги:

  1. Выберите ячейку с числами, которые вы хотите округлить.
  2. Откройте диалоговое окно « Формат ячеек », нажав Ctrl+1 или щелкните правой кнопкой мыши по ячейке и выберите « Формат ячеек » в контекстном меню.

Как округлить число в Excel – Формат ячеек
  1. Во вкладке « Число » выберите « Числовой » или « Денежный » формат и введите число десятичных знаков, которое вы хотите отобразить в поле « Число десятичных знаков ». Предварительный просмотр, как будет округлено число отобразится в разделе « Образец ».
  2. Нажмите кнопку « ОК », чтобы сохранить изменения и закрыть диалоговое окно.

Как округлить число в Excel – Округлить число, изменением формата ячейки

Обратите внимание! Этот метод изменяет формат отображения без изменения фактического значения, хранящегося в ячейке. Если вы ссылаетесь на эту ячейку в любых формулах, то во всех вычислениях будет использоваться исходное число без округления. Если вам необходимо фактически округлить число в ячейке, то используйте функции округления Excel.

Как округлить число функцией ОКРУГЛ

ОКРУГЛ – это основная функция округления чисел в Excel, которая округляет число до указанного количества знаков.

Синтаксис :

Число — любое действительное число, которое вы хотите округлить. Это может быть число или ссылка на ячейку.

Число_разрядов — количество знаков для округления числа. Вы можете указать положительное или отрицательное значение в этом аргументе:

  • Если число_разрядов больше 0, число округляется до указанного количества десятичных знаков. Например, =ОКРУГЛ(17,25; 1) округляет число 17,25 до 17,3.

Чтобы округлить число до десятых, укажите в аргументе число_разрядов значение равное 1.

Как округлить число в Excel – Как округлить число до десятых

Если необходимо округлить число до сотых, задайте аргумент число_разрядов равным 2.

Как округлить число в Excel – Как округлить число до сотых

Для того чтобы округлить число до тысячных, введите 3 в число_разрядов.

Как округлить число в Excel – Как округлить число до тысячных
  • Если число_разрядов меньше 0, все десятичные разряды удаляются, а число округляется слева от десятичной точки (до десятых, до сотен, до тысяч и т. д.). Например, =ОКРУГЛ(17,25; -1) округляет 17,25 к ближайшему кратному 10 числу и возвращает в результате 20.
  • Если число_разрядов равно 0, число округляется до ближайшего целого числа (без десятичных знаков). Например, =ОКРУГЛ(17,25; 0) округляет 17,25 до 17.

На следующем изображении демонстрируются несколько примеров, как округлить число в Excel в формуле ОКРУГЛ:

Как округлить число в Excel – Примеры формул, как округлить число, функцией ОКРУГЛ

Как округлить число в большую сторону функцией ОКРУГЛВВЕРХ

Функция ОКРУГЛВВЕРХ округляет число вверх (от 0) до заданного количества цифр.

Синтаксис :

Число — число для округления.

Число_разрядов — количество знаков, до которых вы хотите округлить число. Вы можете указать как положительные, так и отрицательные числа в этом аргументе, и он работает как число_разрядов функции ОКРУГЛ, описанной выше, за исключением того, что число всегда округляется в большую сторону.

Как округлить число в Excel – Примеры формул, как округлить число в большую сторону, функцией ОКРУГЛВВЕРХ

Как округлить число в меньшую сторону функцией ОКРУГЛВНИЗ

Функция ОКРУГЛВНИЗ в Excel делает противоположное тому, что делает ОКРУГЛВВЕРХ, т. е. округляет число вниз.

Синтаксис :

Число — число, подлежащее округлению.

Число_разрядов — количество знаков, до которых вы хотите округлить число. Работает как аргумент число_разрядов функции ОКРУГЛ, за исключением того, что число всегда округлено в меньшую сторону.

Следующее изображение демонстрирует, как округлить число в Excel в меньшую сторону функцией ОКРУГЛВНИЗ в действии.

Как округлить число в Excel – Примеры формул, как округлить число в меньшую сторону, функцией ОКРУГЛВНИЗ

Так выполняется округление чисел в Excel. Надеюсь, теперь вы знаете, как среди всех этих способов, как округлить число в Excel, выбрать наиболее подходящий для ваших нужд.

Округление чисел в Microsoft Excel

Функционал Microsoft Excel огромен, и одной из главных возможностей программы является работа с числовыми данными. Иногда во время арифметических операций или при работе с дробями программа эти числа округляет. С одной стороны, это практично, поскольку в подавляющем большинстве случаев высокая точность расчетов не нужна, и множество лишних знаков только занимает дополнительное место на экране. Кроме того, есть числа, дробная часть которых бесконечна, поэтому для отображения на экране приходится их немного сокращать. С другой – бывают расчеты, где точность сохранять просто необходимо, а округление приводит к неприятным последствиям.

Для решения подобных вопросов Эксель предлагает следующее решение – задать точность округления пользователь может самостоятельно. Таким образом, программа может быть настроена для вычислений любых видов, позволяя каждый раз находить оптимальный баланс между удобством отображения информации и необходимой точностью вычислений.

Читать еще:  Среднеквадратическое отклонение в excel

Как числа хранятся в Excel и отображаются на экране

Программа Excel умеет работать с двумя типами чисел: точными и приблизительными. Пользователь может выбирать способ их отображения, однако, в самой программе число хранится в точном виде (до 15 знаков после запятой). Поэтому, даже если на экране число будет отображаться до двух знаков после запятой, при расчетах программа будет обращаться к гораздо более точной записи в памяти.

Пользователь может настроить то, как это число будет показано на экране. А округление происходит по общепринятым нормам: числа от 0 до 4 включительно округляются вниз, а с 5 до 9 – вверх.

Настройка отображения чисел через панель инструментов

Самый простой способ округлить число, а точнее, его отображения на экране – через кнопки на Панели инструментов. Чтобы найти их, должна быть открыта вкладка “Главная”, в которой расположен подраздел “Число”. Здесь и находятся требуемые функции “Увеличить разрядность” или “Уменьшить разрядность”.

Выберите ячейку с числом и нажмите на кнопку с нужным действием. Функция “Увеличить разрядность” будет добавлять в конец дробной части нули.

Функция “Уменьшить разрядность” будет убирать цифры с конца, округляя окончания.

Примечание: Важно помнить, что числовое значение, которое хранится в памяти программы после проделанных действий никак не изменится, и расчеты будут производиться с исходным значением.

Формат чисел через контекстное меню

Нужную степень отображаемого на экране округления можно изменить и другим способом – через контекстное меню ячейки.

  1. Выделяем нужную ячейку (или область, состоящую из нескольких ячеек) и кликаем по ней правой кнопкой мыши. В контекстном меню выбираем пункт “Формат ячеек…”.
  2. Откроется окно, в котором в верхнем меню переходим во вкладку “Число” (по умолчанию должна быть установлена именно эта вкладка). В списке слева выбираем “Числовой” формат. Справа находим надпись “Число десятичных знаков”, рядом с которым есть текстовое поле для выбора количества знаков дробной части. Можно ввести его самостоятельно или дойти до нужного значения путем нажатия на стрелки вверх или вниз.
  3. Далее нажимаем на “ОК”, после чего изменения вступят в силу.

Примечание: Также можно поставить галочку напротив надписи “Разделитель групп разрядов”, чтобы при отображении больших чисел разграничить группы разрядов.

Как задать числам требуемую точность при расчетах

Предыдущие примеры затрагивали то, как настроить визуальное отображение числового значения. Но Эксель позволяет задать и точность самих операций с числами. Это полезно, например, при финансовых расчетах, где обычно используются числа только с двумя цифрами после запятой.

Для изменения данного параметра откройте вкладку “Файл” в верхнем меню программы. В новом окне найдите строку “Параметры” в списке слева и нажмите на нее.

На экране должно появиться окно настройки параметров. Здесь переходим в раздел “Дополнительно”, далее находим внизу правой части окна подраздел “При пересчете этой книги”, в котором предлагается выбрать четыре параметра. Напротив второго из них (“Задать указанную точность”) устанавливаем галочку и нажимаем “OK”.

С этого момента при расчетах будет использоваться то значение, которое вы на мониторе.

Важно: Обратите внимание, что настройка будет применена к файлу целиком, а не к отдельному листу, из которого были открыты настройки.

Использование функций округления

Иногда нужно поменять точность расчетов с числовыми данными не для всего файла, а лишь для определенной области ячеек. В этом случае лучшим решением будет использование встроенных функций для работы с округлением чисел, которых существует несколько видов. Вот самые удобные и наиболее популярные:

  • ОКРУГЛ – округление до числа с указанным количеством знаков после запятой по правилам математики.
  • ОКРУГЛВВЕРХ – округление до ближайшего большего значения (по модулю).
  • ОКРУГЛВНИЗ – округление до ближайшего меньшего значения (по модулю).
  • ОКРУГЛТ – округление числа с желаемой точностью.
  • ОКРВВЕРХ – округление с избытком до ближайшего числа, которое кратно заданному значению точности.
  • ОКРВНИЗ – округление с недостатком до числа ближайшего числа, которое кратно заданному значению точности.
  • ОТБР – округление до целого числа путем отбрасывания цифр после запятой.
  • ЧЁТН – округление до ближайшего четного числа.
  • НЕЧЁТ – округление до ближайшего нечетного числа.

Обобщенная формула для первых трех функций выглядит так: ФУНКЦИЯ([число];[количество цифр]). Например, для округления числа 3,14159265 до двух знаков после запятой, нам понадобится следующая формула: =ОКРУГЛ(3,14159265;2).

Пишем ее в нужную ячейку, не забывая в начале поставить знак равно.

После набора формулы щелкаем клавишу Enter и получаем в результате число 3,14.

В формулах функций ОКРУГЛТ, ОКРВВЕРХ и ОКРВНИЗ в качестве второго аргумента указывается кратность округления. Например, если стоит задача округлить число 13 до ближайшего числа, делящегося на 5 без остатка, следует написать следующую формулу: =ОКРУГЛТ(13;5).

Результатом вычисления будет число 15.

Последние три функции (ОТБР, ЧЁТН и НЕЧЁТ) используют всего 1 аргумент – само число или ячейка. Первая из них просто вернет его целую часть, а вторая и третья – ближайшее четное или нечетное числа, соответственно.

Сами функции можно прописать как внутри ячейки, так и в верхней строке формул, которая находится справа от надписи fx.

После того, как вы начнете вводить название функции, программа выдаст подсказки, благодаря которым можно выбрать точное название и избежать возможных опечаток. Перед написанием формулы не забывайте ставить знак равно (“=”).

Читать еще:  Просмотр документов excel онлайн

В дополнение ко всему, есть возможность вызвать функци через вкладку “Формулы”. Откройте ее и выберите “Математические”. Появится список всех функций, расположенных по алфавиту, поэтому для поиска округления (ОКРУГЛ) нужно идти в нижнюю часть списка.

После того, как мы выберем нужную функцию, откроется окно для ее настройки.

В строке “Число” пишем координаты ячейки, значение которой нужно округлить. Также, вместо того, чтобы писать адрес ячейки вручную, можно просто находясь курсором в строке “Число” щелкнуть левой кнопкой мыши по нужной ячейке.

Далее переходим к строке “Число разрядов” и здесь пишем число знаков после запятой. Допустим, в нашем случае, пусть это будет 2.

После того, как все заполнено, нажимаем “OK” и получаем результат в первой строке, куда была вставлена функция округления.

Чтобы применить расчеты к остальным строкам столбца, наводим мышью на нижний правый угол ячейки, содержащей формулу. Курсор поменяет свой вид на небольшой крестик. Теперь, зажав его левой кнопкой мыши тянем формулу на оставшиеся строки, по которым нужно произвести расчет, после чего отпускаем кнопку.

Заключение

Таким образом, в Excel есть два способа произвести округление отображаемой части числа: через панель инструментов и через Формат ячеек. Однако, при этом система будет помнить все число целиком и использовать именно его при расчетах. Поэтому, чтобы изменить само число или задать его точность в расчетах, необходимо либо воспользоваться одной из функций округления, либо изменить настройки в параметрах программы.

Округление чисел в excel в большую и меньшую сторону

При работе с финансовыми документами или бухгалтерскими отчетами очень важно отображение конечных результатов в нужном формате. В зависимости от требований могут быть выведены два знака после запятой или же целое число. Однако стоит учитывать математические законы, и сегодня поговорим о том, как правильно сделать округление в excel.

Формат ячейки

Самый простой способ округления – настройка отображения цифр в ячейке. Для этого необходимо сделать следующее:

  1. Заполняете рабочий лист необходимыми данными.

  1. Щелкаете по нужной ячейке правой клавишей мыши и ищете строку Формат ячеек….

  1. В появившемся окне на первой вкладке выбираете Числовой формат отображения, затем в блоке справа изменяете число десятичных знаков, при этом ниже можно сразу же увидеть результаты форматирования. Подтверждаете действие нажатием клавиши ОК.

Быстрее эту операцию можно провести, используя специальные кнопки в блоке Число во вкладке Главная на Панели инструментов.

Недостатком этого метода является то, что округления не происходит, а изменяется лишь внешний вид числа. Для дальнейшего использования такая цифра не подходит, поскольку в расчетах будут использоваться все знаки после запятой.

Функция ОКРУГЛ

Но как сделать округление, чтобы скорректированные данные можно было использовать дальше, для этого необходимо воспользоваться специальной функцией excel –ОКРУГЛ. Формула содержит аргумент и количество разрядов.

Например, необходимо округлить число до 2 знаков после запятой. Тогда в строке функции будет следующая запись: ОКРУГЛ(C4;2), где С4 – аргумент, а 2 – количество разрядов.

Важно! Excel при округлении руководствуется правилами математики. Если цифра оканчивается от 1 до 4, то округление идет в меньшую сторону, если от 5 до 9 – в большую сторону.

В зависимости от значения второго блока функции можно настроить различные режимы округления:

  1. Чтобы округлить до целого числа, необходимо поставить 0.

  1. До десятков, соответственно 1, до сотен — 2.

  1. Для округления в меньшую сторону до целого необходимо вписать -1 (минус 1).

У функции ОКРУГЛ, есть дополнения, а именно ОКРУГЛВВЕРХ и ОКРУГЛВНИЗ. Формула изменяет число в большую сторону или меньшую сторону соответственно, независимо от цифры, которая стоит последней. При этом синтаксис формулы не меняется.

Дополнительные функции

Excel содержит и более специфические формулы, использование которых необходимо только в исключительных случаях.

Например, функция ОТБР, которая отбрасывает числа от установленного разряда, то есть происходит не округление, а отсечение.

Функция ОКРВВЕРХ позволяет округлять значение ячейки до целого числа, при этом, если необходимо округлить в большую сторону кратно 100, необходимо указать точность 100, а если до 50, то, соответственно, 50.

На заметку! Синтаксис ОКРВВЕРХ отличается от ОКРУГЛ тем, что второй блок не число разрядов, а точность.

Формула ОКРВНИЗ, аналогична предыдущей, только округляется вниз до целого. В зависимости от выбранной точности, можно округлить и до 5, однако это работает только для диапазона значений от 5,00 до 9,99.

Чтобы убрать округление, достаточно удалить из формулы любую из перечисленных функций, при этом исходное значения числа примет первоначальный вид.

Как видите, MS Excel обладает большим набором инструментов для работы с числами. Плюсом является то, что округление можно применять и к суммам, и к результатам вычисления выражений или функций. Описанные выше функции подойдут, как для бухгалтеров и людей, работающих с большими объемами чисел, так и для простых пользователей.

Жми «Нравится» и получай только лучшие посты в Facebook ↓

Ссылка на основную публикацию
Adblock
detector